AFNetworking not compatible with iOS 4.3 AFNetworking not compatible with iOS 4.3 ios ios

AFNetworking not compatible with iOS 4.3


AFNetworking 1.0 and higher requires either iOS 5.0 and above, or Mac OS 10.7 (64-bit with modern Cocoa runtime) and above.

For compatibility with iOS 4.3, use the latest 0.10.x release.

from: https://github.com/AFNetworking/AFNetworking:

UPDATE, specify iOS dependency in Podfile:

platform :ios, '6.0'pod 'FMDB'pod 'AFNetworking'

UPDATE 2, I create a new project and a new Podfile, run pod install:

$ pod installResolving dependencies of `./Podfile'Updating spec repositoriesResolving dependencies for target `default' (iOS 6.0)Downloading dependenciesInstalling AFNetworking (1.0)Installing FMDB (2.0)Generating support files[!] From now on use `AF.xcworkspace'.Integrating `libPods.a' into target `AF' of Xcode project `./AF.xcodeproj'.

UPDATE 3,

screen shot


Specifying your Versions of the desired pods may help.

platform :ios, '6.0'pod 'FMDB', '~> 2.0'pod 'AFNetworking', '~> 1.1.0'

Also make sure you're opening the correct xcworkspace file.


matomo