How to check iOS Version is iOS 6? [duplicate] How to check iOS Version is iOS 6? [duplicate] ios ios

How to check iOS Version is iOS 6? [duplicate]


Check this GitHub Gisthttps://gist.github.com/998472

You can add the code or include it in your ...-Prefix.pch file so you can use it wherever you need it.


EDIT

I'm leaving an example of how you can use the code from Gist so people can check if it's useful for their case. This can also be found over the Gist.

/* *  Usage */ if (SYSTEM_VERSION_LESS_THAN(@"4.0")) {    ...}if (SYSTEM_VERSION_GREATER_THAN_OR_EQUAL_TO(@"3.1.1")) {    ...}


Try this:

Update:

NSArray *vComp = [[UIDevice currentDevice].systemVersion componentsSeparatedByString:@"."];if ([[vComp objectAtIndex:0] intValue] >= 7) {    // iOS-7 code[current] or greater} else if ([[vComp objectAtIndex:0] intValue] == 6) {    // iOS-6 code} else if ([[vComp objectAtIndex:0] intValue] > 2) {    // iOS-3,4,5 code} else {    // iOS-1,2... code: incompatibility warnings, legacy-handlers, etc..  }

Previous code:

NSArray *vComp = [[UIDevice currentDevice].systemVersion componentsSeparatedByString:@"."];if ([[vComp objectAtIndex:0] intValue] == 6) {    // iOS-6 code} else {    // iOS-5, iOS-4... code     }

To specifically check for a subversion of IOS use

float sysVer = [[[UIDevice currentDevice] systemVersion] floatValue];if (sysVer > 6.01) {    // iOS-6.01+ code} else {    // prior iOS versions}


You can get the iOS version as a string using:

[[UIDevice currentDevice] systemVersion]


matomo