Semantic Issue: Property's synthesized getter follows Cocoa naming convention for returning 'owned' objects Semantic Issue: Property's synthesized getter follows Cocoa naming convention for returning 'owned' objects objective-c objective-c

Semantic Issue: Property's synthesized getter follows Cocoa naming convention for returning 'owned' objects


My guess is that the compiler version you’re using follows the memory management rules for declared properties, too — more specifically, for declared properties’ accessors:

You take ownership of an object if you create it using a method whose name begins with “alloc”, “new”, “copy”, or “mutableCopy”.

A property named newTitle, when synthesised, yields a method called -newTitle, hence the warning/error. -newTitle is supposed to be a getter method for the newTitle property, however naming conventions state that a method whose name begins with new returns an object that’s owned by the caller, which is not the case of getter methods.

You can solve this by:

  1. Renaming that property:

    @property (strong, nonatomic) NSString *theNewTitle;
  2. Keeping the property name and specifying a getter name that doesn’t begin with one of the special method name prefixes:

    @property (strong, nonatomic, getter=theNewTitle) NSString *newTitle;
  3. Keeping both the property name and the getter name, and telling the compiler that, even though the getter name starts with new, it belongs to the none method family as opposed to the new method family:

    #ifndef __has_attribute#define __has_attribute(x) 0  // Compatibility with non-clang compilers#endif#if __has_attribute(objc_method_family)#define BV_OBJC_METHOD_FAMILY_NONE __attribute__((objc_method_family(none)))#else#define BV_OBJC_METHOD_FAMILY_NONE#endif@interface ViewController : UIViewController@property (strong, nonatomic) NSString *newTitle;- (NSString *)newTitle BV_OBJC_METHOD_FAMILY_NONE;@end

    Note that even though this solution allows you to keep newTitle as both the property name and the getter name, having a method called -newTitle that doesn’t return an object owned by the caller can be confusing for other people reading your code.


For the record, Apple have published Transitioning to ARC Release Notes, in which they state:

You cannot give a property a name that begins with new or copy.

They’ve already been notified that their statement is not quite accurate: the culprit is the getter method name, not the property name.


Edit 17 Jan 2015: I’ve just noticed a recent commit to Clang that suggests option 3 above (using objc_method_family(none)), including a fix-it, for the general case where a property name matches one of the special method family prefixes. Xcode will likely incorporate this change eventually.


Unacceptable Object Names

  • newButton
  • copyLabel
  • allocTitle

Acceptable Object Names

  • neueButton
  • mCopyLabel
  • _allocTitle

#arc #auto-synthesized #xcode-4.6.1

** EDIT **

Apparently you can't use mutableCopy either.


The name of the member starting with new is what triggers the warning. Change the name to editedTitle and the warning will go away. I was unable to find documentation confirming this but through testing was able to determine that member variables that begin with 'new' aggravate the compiler.