Could not find a version that satisfies the requirement tensorflow Could not find a version that satisfies the requirement tensorflow python python

Could not find a version that satisfies the requirement tensorflow


As of October 2020:

  • Tensorflow only supports the 64-bit version of Python

  • Tensorflow only supports Python 3.5 to 3.8

So, if you're using an out-of-range version of Python (older or newer) or a 32-bit version, then you'll need to use a different version.


There are a few important rules to install Tensorflow:

  • You have to install Python x64. It doesn't work on 32b and it gives the same error as yours.

  • It doesn't support Python versions later than 3.8 and Python 3.8 requires TensorFlow 2.2 or later.

For example, you can install Python3.8.6-64bit and it works like a charm.


I installed it successfully by pip install https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.8.0-py3-none-any.whl


matomo